Other 1977 Kawasaki KE250 Enduro

SRAD97750

Moderator
Staff member
oil tank is under the seat. The oil pump is the front half of the clutch cover. You can pull the pump lines and premix. But you have to jet the carburetor for the added oil in the fuel through the jets. Otherwise you'll run too lean.

I have been told the oil pumps on these KE's are excellent. Mine pumped great. OIL OR NOTHING.
 
Hey Dan do you still have this bike?

I just picked one up about two months ago.
Engine is solid and bike was mostly complete. It's a 1977. Here's what I have done so far.

Ordered new oil tank and got oil injection running
Replaced card float
Installed new battery
Re coated inside of gas tank

And these are the parts I have in order.

Shinko 705 tires and tubes
Bearings
Brake shoes
O ring chain
Front and rear sprockets
Exhaust gasket
Spark plugs.

I should have this beauty running to full potential by this weekend. Here's a pic so far

image.jpg
Gas tank has one small dent and seat is perfect. Paid $200
 
I do not have it anymore, but it was an awesome ride while I did pilot it.
Have a ton of fun on that thing!!! -BIG DAN:thumb:
Aww man that stinks. Your like one of the only people I've seen with a really good video on YouTube who had a running ke250. What are you riding now?
 

SRAD97750

Moderator
Staff member
Aww man that stinks. Your like one of the only people I've seen with a really good video on YouTube who had a running ke250. What are you riding now?
Thanks! I felt it was quite rare as well.
Been riding my off road bikes mostly. WR500 and the yard-quad... -BIG DAN:smirk:
 
Hey Dan do you still have this bike?

I just picked one up about two months ago.
Engine is solid and bike was mostly complete. It's a 1977. Here's what I have done so far.

Ordered new oil tank and got oil injection running
Replaced card float
Installed new battery
Re coated inside of gas tank

And these are the parts I have in order.

Shinko 705 tires and tubes
Bearings
Brake shoes
O ring chain
Front and rear sprockets
Exhaust gasket
Spark plugs.

I should have this beauty running to full potential by this weekend. Here's a pic so far

View attachment 26873
Gas tank has one small dent and seat is perfect. Paid $200
Sweet ride Jamie....welcome to DBA. I'm sure you will enjoy that old bike.
 
Hey Dan do you still have this bike?

I just picked one up about two months ago.
Engine is solid and bike was mostly complete. It's a 1977. Here's what I have done so far.

Ordered new oil tank and got oil injection running
Replaced card float
Installed new battery
Re coated inside of gas tank

And these are the parts I have in order.

Shinko 705 tires and tubes
Bearings
Brake shoes
O ring chain
Front and rear sprockets
Exhaust gasket
Spark plugs.

I should have this beauty running to full potential by this weekend. Here's a pic so far

View attachment 26873
Gas tank has one small dent and seat is perfect. Paid $200


Welcome!!!
Sweet vintage curb jumper!:thumb:
 
So I got all the parts installed yesterday and my buddy who helped me took her out for her maiden voyage. When he returned he kept it idle and it shut off by it self. Now it won't kick over any longer. We found that there is no spark. Tried a couple different plugs that were new. Today he went through the whole wiring harnes and fixed any wires that looked shady. Can't find the issue. Does anyone out there have a pdf repair manual for this bike. I can't find any online.
 
image.jpg So while I wait to figure out what the problem is with spark, I decided to order some other things. Service manual hopefully should be in this coming weekend. Also ordered clutch cover gasket, blinker lense and fork seals. One thing I cannot find is a spark arrester and exhaust cap. I guess those are pretty rare.

Here is a pic of the tires I picked up for it.
 
Last edited:
So I received the cdi and got it installed. It had spark so I continued re assembling the bike. Then checked for spark again and nothing. Either I burnt out another cdi or I'm missing something.
 
Lots of times you can have cap and wire problems that act like that. Old switches etc .. ttim the plug wire and try a new cap . Sparkies are cheap and work
 
Last edited:
Top